Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 18, 2026 - 21:00 CEST
Scheduled
We are expanding our core network infrastructure to further improve capacity and resilience. During this maintenance, you may experience brief periods of packet loss or intermittent connectivity.
Posted Aug 18, 2026 - 18:10 CEST
This scheduled maintenance affected: Infrastructure (FRA14, Interxion) (Core Network).