Network disturbance

Incident Report for LUMASERV

Identified

The network is available again since 19:24 CET. We continue investigating and analyzing the route cause.
Posted Feb 16, 2026 - 19:30 CET

Investigating

We are currently experiencing network issues at our location in Frankfurt. We are currently investigating and provide updates on this page as soon as possible.
Posted Feb 16, 2026 - 19:19 CET
This incident affects: Infrastructure (FRA14, Interxion) (Core Network).