We identified that Cloudflare DNS has major issues, causing some servers using Cloudflare DNS to have dns resolution issues. This is not an issue on our side but we'll keep monitoring it.
We identified that Cloudflare DNS has major issues, causing some servers using Cloudflare DNS to have dns resolution issues. This is not an issue on our side but we'll keep monitoring it.
Posted Jul 15, 2025 - 00:11 CEST
Investigating
We are seeing issues regarding routes to Cloudflare, we're investigating and will update you as soon as we have further information.
Posted Jul 15, 2025 - 00:06 CEST
This incident affected: Infrastructure (FRA14, Interxion) (Core Network).